Forum Navigation
You need to log in to create posts and topics.

Pods stuck in pending state: node(s) didn't have free ports for the requested pod ports

Problem

Warning  FailedScheduling  3m45s (x13 over 64m)  default-scheduler  0/4 nodes are available: 1 node(s) didn’t have free ports for the requested pod ports. preemption: 0/4 nodes are available: 4 No preemption victims found for incoming pod.

Solution

Option A

Usually this issue is a network related between the control-plane and the worker nodes. check that your firewall is disabled on the worker-node and make sure to open all communication between worker-nodes and control-plane

Option B

If you set the control plane and the worker-nodes on a different network ( with firewall between them ) it can affects the performance and the test your setup with all the servers on the same network to eliminate network connectivity issues

If you have found my website, guides, articles or videos useful, please buy me a coffee